1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

win XP pro + ATI Radeon 9600 Pro + SRS or PLayboy the Mansion - Problems!

Discussion in 'ATI' started by David Ferreira, May 17, 2005.

  1. Hi.

    I've been happily running my PIV 2.8, 1gb ddr and ATI Radeon 9600 Pro
    (256 ddr), for everything including the latest games like KOTOR 2.
    No video problems, nothing wrong.

    recently, I've installed 2 games that simply refuse to work, and I
    think the problem is with my radeon 9600...

    with Street Racing Syndicate, it starts up, goes through a few screens
    (credits or whatever) and straight after the namco screen, when I
    assume the 3D engine would start doing its work, it goes straight back
    to the desktop, terminating the game.
    No Event viewer messages or anything...

    With Playboy - The Mansion, after I launch, the screen goes black, but
    On, and the only thing I can see is the cursor... which when I move it
    around the screen, changes types... if I press escape, it drops out,
    once again, no error message or event viewer..

    I've already updated the via drivers, got the latest directx
    installed, installed the new catalyst drivers...
    Still nothing.
    Im out of Ideas. anyone know what this could be?

    ps.: most other games run fine... even very memory intensive ones like
    Doom III.
     
    David Ferreira, May 17, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.