Windows XP install problem - SATA disk

Discussion in 'Gigabyte' started by pixel, Feb 9, 2005.

  1. pixel

    pixel Guest

    i've installed sata OS disks with winXP before, but this is a new kind
    of sata problem.

    motherboard: Gigabyte GA-K8NXP-SLI [Sil 3114 sata raid controller], 36GB
    raptor boot disk (no other hard drives), XP pro with SP2.

    ok, the cd booted ok, installed the SATA controller (from Sil3114
    folder) after hitting F6... XP install found the disk (yay)....
    formatted the drive.... all files copied ok....remove floppy and CD for
    reboot... then:
    DISK BOOT FAILURE.

    so basically i think the problem is not with the driver or windows
    install but in the bios. as a first, second or third boot device i can't
    select "sata" or "scsi", just "hard disk". i remember from past installs
    having to set it to SCSI but that's not anywhere in the BIOS. there's no
    other SATA options in the bios except for enabling and disabling
    SATA-RAID, i've tried both and they give the same result.

    the Gigabyte website outlines this procedure to set sata boot disk:
    ---
    1. Advanced BIOS features--> SATA/RAID/SCSI boot order: "SATA"
    2. Advanced BIOS features--> First boot device: "SCSI"
    3. Integrated Peripherals--> Onboard H/W Serial ATA: "enable"
    Then it depends on the SATA mode that you need to set "RAID" to RAID
    mode or "BASE" to normal ATA mode in the item named Serial ATA function.
    ---
    none of that even remotely resembles the bios of this mobo. the word
    "sata" isn't even mentioned in advanced bios features.

    either the bios is a piece of crap (likely) or the disk itself is
    stuffed. any ideas...? :)
     
    pixel, Feb 9, 2005
    #1
    1. Advertisements

  2. BIOS, or user error.
     
    Richard Dower, Feb 9, 2005
    #2
    1. Advertisements

  3. pixel

    Mercury Guest

    Did you leave the floppy in the drive? It gets read twice.
    Did you actually see visual confirmation that the driver loaded?
    "Press F6 early and Often" as the MS guys say.

    Have you checked for bios updates?
     
    Mercury, Feb 9, 2005
    #3
  4. pixel

    pixel Guest

    if the files were copied to the drive, then the XP install saw the drive
    so obviously the driver loaded. its amazing how many ppl have no clue
    what they're talking about here.
    not sure if i can install bios updates without windows installed...? but
    yep i have checked.

    apparently had to hit ctrl-F1 to get into advanced bios not just
    delete....? so will try that today.
     
    pixel, Feb 9, 2005
    #4
  5. pixel

    Mercury Guest

    The driver files can be read TWICE off the floppy. Once to use them as run
    time drivers, the other to actually install them. If the boot device needs
    the drivers for correct operation then the files need to be loaded as
    drivers before they can be installed. This is why the MS people say "Press
    F6 early and often".

    I recommend disconnecting all storage devices during setup. USB flash discs,
    IDE and other drives can result in a failed install or a really stuffed up
    on (boot files in the wrong place). Alos disable all mobo controllers in the
    bios that you are not using.

    The SLI boards are very new... First step may be to update the bios and
    check for mobo and driver updates. You can certainly update the bios without
    windows - using Windows is the worst way.

    Best of luck...
     
    Mercury, Feb 10, 2005
    #5
  6. pixel

    RM Guest

    If the SATA disk doesn't appear on the boot order screen then the bios
    hasn't registered that it exists yet. Disable every RAID option on the
    Integrated Peripherals and turn off all the PATA and unused SATA ports, make
    sure your drive is plugged into port 0 (which isn't the top one). Restart
    the BIOS and it should then appear during the detection phase, go back into
    the BIOS and it will be on the boot order screen.

    You shouldn't need any drivers to install windows, once the BIOS has the
    drive acknowledged correctly. But you will need to reformat the drive before
    installing windows - don't skip this as the current format is corrupt.

    The manual for all the gigabyte boards is awful, the most important bits
    simply aren't there.
     
    RM, Feb 10, 2005
    #6
  7. pixel

    pixel Guest


    the fact that i mentioned that "the windows XP files were copied"
    indicates that i must have done the F6 routine successfully otherwise
    the disk would never have been seen nor the XP files copied.
     
    pixel, Feb 11, 2005
    #7
  8. pixel

    Paul H Guest

    did the cntrl f1 from bios main menu bring up the option you need?
     
    Paul H, Feb 11, 2005
    #8
  9. pixel

    pixel Guest


    windows installation is independant of bios disk recognition. the disk
    always appears in the boot-up screen, so the bios can see it, the
    problem is the bios is of such poor design that it can't select sata or
    scsi as a bootable option. we have the latest bios version, version 6
    for this mobo.

    the only time we were able to get the raptor selectable in the bios
    "hard disk boot priority" was by setting it up as a jbod single raid
    disk, not ideal... and we still needed drivers to get the XP install to
    see the drive. windows install would crash whenever it tried to copy files.

    you have to wonder why some bios/mobo manufactuerers are so lazy not to
    implement a basic boot options for sata, its fast becoming the new
    standard in desktop and workstation hard drives.
     
    pixel, Feb 11, 2005
    #9
  10. pixel

    Mercury Guest

    ahhhhh, it doesn't, but i believe you.
    Many pull the disc out asap.
     
    Mercury, Feb 12, 2005
    #10
  11. pixel

    TijN Guest

    PIXEL. i have the exact same MB, and the exact same problem.

    i have Raid 0, 2x200gig sata's

    and i have the exact problem you are talkign about.

    windwos and all that just seems to lock up somewhere on the install
    process, i've tryed XP SP2 and just plain XP org.

    both have problems, and it never gets through th ewhole installation.
     
    TijN, Feb 22, 2005
    #11
  12. pixel

    xer0w Guest

    I have the same problem also, XP either hangs during the file copy
    stage (after F6 to install the drivers) or reboots, I tried every SiL
    3114 driver I could find but nothing worked.
    I thought it might be a hardware problem, until I read other people
    having the same problem. I also managed to install Mandrake Linux 64
    with no issues whatsoever! (with the same BIOS / RAID config)

    I have concluded that the SiL 3114 XP driver & Gigabyte embedded
    controller combination is a piece of crap and is probably being beta
    tested by the consumer (us :(. I also found Giga-Byte support utterly
    useless.

    I did however get this mobo working with SATA and XP, simple really,
    just plug the SATA disks into the nVidia SATAII onboard controller
    instead, use the supplied driver and configure each disk as spanning
    if no RAID is required, this will configure each one as a JBOD.

    Hope that helps.

    Xer0w
     
    xer0w, Feb 28, 2005
    #12
  13. pixel

    Venom Guest

    I have the GA-K8NXP-SLI mobo and was having the same problems with the
    SATA drive.

    I contacted Gigabyte and they got back to me in exactly 7 days :x ,
    and with the drivers :) needed for both SATA 1 and SATA 2.

    It's a little too late now cause I did what XerOw did by pluging into
    the SATA 2 port and I don't want to go through the headache :cry: of
    loading windows again.

    Venom
     
    Venom, Mar 11, 2005
    #13
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.