Windowserver problem on 10.4.2 fresh install and irrelevant fixes

Discussion in 'Apple' started by Ilgaz Ocal, Jul 25, 2005.

  1. Ilgaz Ocal

    Ilgaz Ocal Guest

    Hi,

    This thing is interesting because of its hotfix.

    I had windowserver using up to 30% of CPU, but I had my Tiger messed up
    because of modem problems and messing with the kernel so I ignored it.

    A user on IRC told me its something to do with keyboard settings.
    That's right, the keyboard mapping! Although it sounded stupid, I had
    no other choice and I tried it.

    The thing he suggests (which he reported to apple indeed) is

    1) Enable root
    2) Login as root, remove all keyboard menus except english
    3) Reboot and add them to your user again disabling the root of course

    This is not the bug which is fixed with 10.4.1 update. It happens on
    10.4.2 and the reset firmware trick with removing windowserver.plist
    -of course- doesn't help.

    Another interesting thing is, verified by its author, YASU utility's
    options and rebooting fixes the huge CPU usage too. I accidentally
    tried it and got amazed that it’s fixed. I spoke with its author he
    says he had a couple of more reports from his users.

    30% CPU usage is blocking type CPU usage. E.g. it’s not "idle" or
    "Sleep" state. E.g., if you have 1 ghz g4, under this situation, it
    will become 700 mhz.

    I think there is a very tiny file somewhere which we can't guess either
    gets deleted or rotated (in case it’s a log) fixes this issue. That's
    why I post to usenet.

    The issue is major indeed.

    Ilgaz
     
    Ilgaz Ocal, Jul 25, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.