1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

Wrong screen is main display (TwinView)

Discussion in 'Nvidia' started by Tassilo Horn, Sep 20, 2005.

  1. Tassilo Horn

    Tassilo Horn Guest

    Hi,

    I have a laptop to which I connected a second monitor. I use TwinView to
    stretch my screen over both monitors and TwinView's Xinerama extension
    to let applications maximize only on one monitor.

    This works good far. But one problem remains:

    The second monitor is the main screen. My login manager (KDM) and KDE's
    panel are displayed on it. Of course I want my laptop's monitor to be
    the main screen (screen 0) and the second monitor should be screen 1.

    How do I achieve this goal?

    This is the Device-Section of my xorg.conf:

    ,----[ /etc/X11/xorg.conf ]
    | Section "Device"
    | Identifier "GeForceTwinView"
    | VendorName "nvidia"
    | Driver "nvidia"
    | Option "DPMS"
    | BusID "PCI:1:0:0"
    | Option "AllowGLXWithComposite" "true"
    | Option "HWCursor" "on"
    | Option "CursorShadow" "on"
    | Option "CursorShadowAlpha" "32"
    | Option "CursorShadowXOffset" "5"
    | Option "CursorShadowYOffset" "5"
    | Option "NvAGP" "1"
    | Option "NoLogo" "on"
    | Option "TwinView" "on"
    | Option "SecondMonitorHorizSync" "31-82"
    | Option "SecondMonitorVertRefresh" "55-120"
    | Option "TwinViewOrientation" "RightOf"
    | Option "MetaModes" "1400x1050, 1400x1050"
    | EndSection
    `----

    Much thanks in advance,
    Tassilo
     
    Tassilo Horn, Sep 20, 2005
    #1
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.