X11 application on remote computer: problem and solution

Discussion in 'Apple' started by Donald H. Gudehus, May 26, 2005.

  1. After upgrading to Mac OS X 10.4 (Tiger) I found that I could no longer
    display X Window applications running on a remote computer. The error
    message was:
    X11TransSocketINETConnect: Can't connect: errno = 111

    That is, after bringing up X11 on your Mac you do
    1) xhost +IP_of_remote_computer
    2) ssh remote_computer
    3) setenv DISPLAY IP_of_my_Macintosh:0
    4) xterm

    Alternately (as I recently learned)
    1) ssh -X remote_computer
    2) xterm

    or same as above but with -Y

    Other accounts on my Mac didn't have this problem. I had changed the
    password on my account on the Mac but changing the password on another
    account didn't reproduce this problem. After some trial and error I
    found that tossing out the file /Users/my_account/Library/
    solved the problem (the system will automatically generate a new and
    functional file).

    Donald H. Gudehus, May 26, 2005
    1. Advertisements

  2. it could be that the ssh_config file in Tiger has set 'ForwardX11 no' as
    the default, instead of 'ForwardX11 yes'.

    but ya, the -X option works too.
    johnny bobby bee, May 26, 2005
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.