1. This forum section is a read-only archive which contains old newsgroup posts. If you wish to post a query, please do so in one of our main forum sections (here). This way you will get a faster, better response from the members on Motherboard Point.

x40 Crashes when the power is unplugged

Discussion in 'IBM Thinkpad' started by e.b. scharff, Jan 19, 2006.

  1. e.b. scharff

    e.b. scharff Guest

    I'm running a dual-boot windows XP / linux Thinkpad x40.

    It's not the copy of windows that came with the thinkpad (I had to
    install a commercial copy because the original copy was regionalized to
    Korea).

    When running windows, if you unplug the power cable from the laptop, it
    produces a serious error (blue screen of death) and crashes the
    machine. This problem does not occur when I'm running linux, and it
    does not produce this error if you unplug the the wall-socket end of
    the power cable without taking the other end out of the machine.

    I'm puzzled (and sort of irritated). Has anyone seen this before?
     
    e.b. scharff, Jan 19, 2006
    #1
    1. Advertisements

  2. e.b. scharff

    cmdrdata Guest

    I suggest you check the version of your BIOS, and then go to their
    website to verify that you have the latest version. If your battery is
    good, then this is probably BIOS functionality for checking power
    source status that may be corrupted. You may have to re-flash your BIOS
    with the latest.

    I had similar problem with a 240X a long time ago where the system does
    not know that it is running on battery power if you disconnect the AC
    source after the display is closed and the system crashed. It worked ok
    if I disconnect then close the lid.
     
    cmdrdata, Jan 19, 2006
    #2
    1. Advertisements

  3. e.b. scharff

    e.b. scharff Guest

    Thanks for the advice, cmdrdata.

    I've tried updating to the latest BIOS version using the utility
    Lenovo's software installer downloads, which didn't fix it. I will
    check the IBM site to make sure there's not a newer version listed, but
    I'm pretty sure I have the latest BIOS.

    Is there maybe some kind of specialized BIOS that's specific to the x40?
     
    e.b. scharff, Jan 19, 2006
    #3
  4. Very simple fix. First though - if you have it in a media slice (dock or
    port replicator,) remove it.

    1. Go to Display Properties.
    2. Click the "Settings" tab.
    3. Click the "Advanced" radio button.
    4. Click the "Intel(R) Extreme Graphics 2 for Mobile" tab.
    5. Click the "Graphics Properties" radio button.
    6. Click the "Power Schemes Settings" radio button.
    If you are in a dock - you won't see the Power Schemes Settings button.
    7. UN-check the "Intel(R) Dual-Frequency Graphics Technology box on the
    right side (Running on Battery.)

    This should correct the locking up or blue screens.

    Hope this helps.
     
    Cleveland Tech, Jan 21, 2006
    #4
  5. e.b. scharff

    testing_h Guest

    This is in all likelihood the battery. i have experienced a similar
    issue on the TP600 where the machine refuses to run except in Safe Mode
    with the battery installed. Also the machine will not run from battery
    even for a second, we have speculated that it is a power drain issue
    (perhaps a shorted cell)

    Regards,
    -A

    email extend the instrument to make it work
     
    testing_h, Jan 21, 2006
    #5
  6. Sorry - not the battery -

    I did forget to post the source of the fix - it's direct on IBM's web site -
    it only affects X40's -

    http://www-307.ibm.com/pc/support/site.wss/document.do?sitestyle=lenovo&lndocid=MIGR-54956

    This is a documented issue that only affects the X40. I have never seen it
    on any of the X20, X30 series, nor on my X41 Tablet.

    Never saw it on any of the 755, 760, 770, 600, 600E, 600X, T20, T21, T22,
    T23, T40, T41 or T42's that I've used or worked with.
     
    Cleveland Tech, Jan 22, 2006
    #6
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.