"You cannot open the application because it may be damaged or incomplete"

Discussion in 'Apple' started by isw, Apr 23, 2006.

  1. isw

    isw Guest

    This is on Tiger, running on a Blue & White.

    A while back, I downloaded and installed "Audacity", and used it (I had
    used the OS 9 version quite a bit previously). It worked fine.

    Today, I tried to launch it again and got a dialog saying "You cannot
    open the application "Audacity" because it may be damaged or incomplete".

    Well, that's kind of odd, but OK. I still have the .dmg so I just
    dragged the whole folder to the trash, opened the .dmg, and dragged the
    contents to my Applications folder. Same error message.

    Tried trashing the prefs file -- same message.

    Tried repairing permissions -- same message.

    Tried running it directly from the mounted dmg -- worked fine.

    Tried installing from the dmg to a second physical disk -- worked fine.

    So the thing did work but now will not work from my boot disk, but will
    work from the mounted dmg, or from another physical disk.

    What's going on here, and how do I fix it?

    Isaac
     
    isw, Apr 23, 2006
    #1
    1. Advertisements

  2. isw

    zit Guest

    1.2.2 works fine for me on 10.4.6.
    I have it in ~/Applications which is not on the boot volume.

    Did you try both /Applications and ~/Applications?

    If you Spotlight "Audacity" does anything interesting turn up?

    Does it work under a different userid?
     
    zit, Apr 23, 2006
    #2
    1. Advertisements

  3. isw

    isw Guest

    Thanks for the helpful hints. There was indeed some problem with the
    file structure, but while AppleJack claimed to have fixed that, the fix
    did not allow Audacity to run.

    Poking around, I discovered that I had inadvertently configured that
    drive to "Case Sensitive" (the other drive, from which the app would
    run, was not), and from the net I learned that could cause problems if
    some of the files buried inside .app packages had unfortunate names.

    I was having some problems with that drive a while back, that caused me
    to reformat it; it's just possible that the case sensitive parameter got
    selected at that time. Perhaps that's what "broke" Audacity.

    I poked around for an easy "switch" to turn off the case sensitivity,
    but nothing showed up so I used Carbon Copy Cloner to move everything
    off the disk, fixed the case switch, moved everything back, and now
    Audacity runs just fine.

    Isaac
     
    isw, Apr 24, 2006
    #3
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.
Similar Threads
There are no similar threads yet.
Loading...