My computer won't recognize monitor, mouse, keyboard

Discussion in 'Technical Support' started by rnnr4202001, Mar 21, 2010.

  1. rnnr4202001

    rnnr4202001

    Joined:
    Mar 21, 2010
    Messages:
    2
    Likes Received:
    0
    I built a gaming PC about 3 months ago, Everything ran great, until last night.

    Now my computer starts up but;
    No beep, so probably no post test?
    my monitor searches and then displays "check signal cable"
    mouse dead
    keyboard wont light

    What does work are fans, dvd drive, lights on Motherboard, lights on PS.

    Interesting side note is I have to push the CPU cooler fan to get it running. Once started fans stays running. So maybe the CPU heated up and died? Could the CPU be fried? Causing the no post test?
     
    rnnr4202001, Mar 21, 2010
    #1
    1. Advertisements

  2. rnnr4202001

    rnnr4202001

    Joined:
    Mar 21, 2010
    Messages:
    2
    Likes Received:
    0
    Here is my computer components. Don't know if this will help.

    SAMSUNG Spinpoint F3 HD502HJ 500GB 7200 RPM 16MB Cache SATA 3.0Gb/s 3.5" Internal Hard Drive -Bare Drive

    ASUS M4A79XTD EVO AM3 AMD 790X ATX AMD Motherboard - Retail
    Xtreme Design w/ CrossfireX support, DDR3 1800 OC

    HIS H577FM1GD Radeon HD 5770 1GB 128-bit GDDR5 PCI Express 2.0 x16 HDCP Ready CrossFireX Support Video Card

    OCZ Fatal1ty OCZ550FTY 550W ATX12V / EPS12V SLI Ready CrossFire Ready Modular Active PFC Power Supply

    G.SKILL 4GB (2 x 2GB) 240-Pin DDR3 SDRAM DDR3 1333 (PC3 10600) Dual Channel Kit Desktop Memory Model F3-10600CL8D-4GBHK

    AMD Athlon II X3 435 Rana 2.9GHz 3 x 512KB L2 Cache Socket AM3 95W Triple-Core Processor

    Windows7 64bit
     
    rnnr4202001, Mar 21, 2010
    #2
    1. Advertisements

Ask a Question

Want to reply to this thread or ask your own question?

You'll need to choose a username for the site, which only take a couple of moments (here). After that, you can post your question and our members will help you out.